summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-01-29 01:10:31 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-03-05 17:58:22 +0100
commitde1aaf76f379f6e42cdd47feef1554126c1d2e13 (patch)
treef2184dc5868dbb5207369b138baabb4b7dd076be /po/CMakeLists.txt
parent71c9cc0fa75dfdd746d635e07ce80e91301153fc (diff)
downloadamarok-de1aaf76f379f6e42cdd47feef1554126c1d2e13.tar.gz
amarok-de1aaf76f379f6e42cdd47feef1554126c1d2e13.zip
Conversion to the cmake building system based on S.Amelian's work.
The embedded sqlite3 has been upgraded to 3.4.2 . Added few man pages taken from the Debian packaging system. Rework of the README and INSTALL files. Signed-off-by: gregory guy <gregory-tde@laposte.net> Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 16ec57d25f13f92bd0d84317f1679fef3b98eeaa)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 52b30c06..c7308e2e 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -9,9 +9,10 @@
#
#################################################
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} amarok.po )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} PATH )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
tde_create_translation( FILES ${_po} LANG ${_lang} )
endforeach( )