summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44cfd0ef..7ff5907d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,12 @@ option( WITH_XINE "Enable xine-engine support" OFF )
option( WITH_LIBGPOD "Enable iPod support from libgpod" OFF )
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -68,6 +74,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### source directories ########################
add_subdirectory( amarok )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
##### write configure files #####################