summaryrefslogtreecommitdiffstats
path: root/artsc/CMakeLists.txt
diff options
context:
space:
mode:
authorFrançois Andriot <francois.andriot@free.fr>2014-11-26 09:08:52 +0100
committerSlávek Banko <slavek.banko@axis.cz>2014-11-26 09:11:35 +0100
commit775e3e4645343770d70538302d91c8adf83ac4b4 (patch)
tree327065cf5aaedd71da3d31e7b23e0b91e605e672 /artsc/CMakeLists.txt
parentaa7d3725f3a2d9561fcdf03f04d8332bb9722f93 (diff)
downloadarts-775e3e4645343770d70538302d91c8adf83ac4b4.tar.gz
arts-775e3e4645343770d70538302d91c8adf83ac4b4.zip
Fix artsc-config script to return valid include directoryr14.0.0
Fix FTBFS on openbsd This resolves Bug 2160 Signed-off-by: François Andriot <francois.andriot@free.fr>
Diffstat (limited to 'artsc/CMakeLists.txt')
-rw-r--r--artsc/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/artsc/CMakeLists.txt b/artsc/CMakeLists.txt
index 59833c1..71f8baa 100644
--- a/artsc/CMakeLists.txt
+++ b/artsc/CMakeLists.txt
@@ -17,8 +17,10 @@ add_definitions( -DCOMPILING_ARTSC )
set( prefix ${CMAKE_INSTALL_PREFIX} )
set( exec_prefix $prefix )
set( libdir ${LIB_INSTALL_DIR} )
-set( includedir ${INCLUDE_INSTALL_DIR} )
-set( LIBDL -l${DL_LIBRARIES} )
+set( includedir ${CMAKE_INSTALL_PREFIX}/include/artsc )
+if( NOT "${DL_LIBRARIES}" STREQUAL "" )
+ set( LIBDL -l${DL_LIBRARIES} )
+endif( )
set( USE_THREADS )
set( LIBPTHREAD ${CMAKE_THREAD_LIBS_INIT} )
foreach( LIB ${GTHREAD2_LIBRARIES} )
@@ -57,7 +59,7 @@ include_directories(
# FIXME: DESTINATION is currently a workaround
install( FILES
artsc.h ${CMAKE_CURRENT_BINARY_DIR}/artsc_export.h
- DESTINATION ${CMAKE_INSTALL_PREFIX}/include/artsc )
+ DESTINATION ${includedir} )
##### artsdsp (shared lib) ######################