summaryrefslogtreecommitdiffstats
path: root/soundserver/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-07-04 10:09:07 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-07-04 10:09:31 +0900
commit1ee7912f7e9c9da142c14ebc38f3db188fe86d4e (patch)
treee34c47bbdaa55fdda7bdbcb32a4ab3246d2ed97e /soundserver/CMakeLists.txt
parent1b0b9f6271e8819932af07651760484fcd909e14 (diff)
downloadarts-1ee7912f7e9c9da142c14ebc38f3db188fe86d4e.tar.gz
arts-1ee7912f7e9c9da142c14ebc38f3db188fe86d4e.zip
cmake: Use set_property( SOURCE ... COMPILE_DEFINITIONS )
instead of set_source_files_properties( ... COMPILE_FLAGS ) to avoid the problem of double escaping quotation marks. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit c1b7409de9bfd0c63c662b38b007d99dbb442d38)
Diffstat (limited to 'soundserver/CMakeLists.txt')
-rw-r--r--soundserver/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/soundserver/CMakeLists.txt b/soundserver/CMakeLists.txt
index 0f46bed..befa698 100644
--- a/soundserver/CMakeLists.txt
+++ b/soundserver/CMakeLists.txt
@@ -165,7 +165,7 @@ tde_add_executable( artswrapper
# FIXME "artsdpath" seems inconsistent name
# necessary for artswrapper
SET( artsdpath ${BIN_INSTALL_DIR}/artsd )
-set_target_properties( artswrapper PROPERTIES COMPILE_FLAGS -DEXECUTE=\\"${artsdpath}\\" )
+set_property( TARGET artswrapper APPEND PROPERTY COMPILE_DEFINITIONS EXECUTE="${artsdpath}" )
##### artsshell #################################