summaryrefslogtreecommitdiffstats
path: root/flow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'flow/CMakeLists.txt')
-rw-r--r--flow/CMakeLists.txt142
1 files changed, 48 insertions, 94 deletions
diff --git a/flow/CMakeLists.txt b/flow/CMakeLists.txt
index 2f7325c..4231957 100644
--- a/flow/CMakeLists.txt
+++ b/flow/CMakeLists.txt
@@ -13,83 +13,55 @@ add_subdirectory( mcopclass )
add_subdirectory( gsl )
add_subdirectory( gslpp )
-set( artsflow_INCS
- ${CMAKE_CURRENT_BINARY_DIR}/artsflow.h
- audiosubsys.h
- cache.h
- cachedwav.h
- convert.h
- pipebuffer.h
- stdsynthmodule.h
- synthschedule.h
- fft.h
- artsflow.idl
- audioio.h
- resample.h
- cpuinfo.h
- bufferqueue.h
- gslschedule.h
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/mcop
+ ${CMAKE_SOURCE_DIR}/mcop
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${GLIB2_INCLUDE_DIRS}
)
-set( artsflow_SRCS
- synth_play_impl.cc
- gslschedule.cc
- audiosubsys.cc
- pipebuffer.cc
- convert.cc
- synth_wave_sin_impl.cc
- synth_frequency_impl.cc
- synth_multi_add_impl.cc
- synth_add_impl.cc
- synth_mul_impl.cc
- synth_play_wav_impl.cc
- stdsynthmodule.cc
- cache.cc
- asyncschedule.cc
- bytestreamtoaudio_impl.cc
- stereovolumecontrol_impl.cc
- stereoeffectstack_impl.cc
- fft.c
- stereofftscope_impl.cc
- virtualports.cc
- bus.cc
- audiomanager_impl.cc
- synth_record_impl.cc
- resample.cc
- audioio.cc
- audioiooss.cc
- audioioalsa.cc
- audioioalsa9.cc
- audioionull.cc
- audioiolibaudioio.cc
- audioioesd.cc
- audioiojack.cc
- audioiosun.cc
- audioioaix.cc
- audioionas.cc
- cpuinfo.cc
- audioioossthreaded.cc
- audiotobytestream_impl.cc
- audioiosgi.cc
- audioiocsl.cc
- audioiomas.cc
- datahandle_impl.cc
-)
-include_directories(
- ${CMAKE_BINARY_DIR} # for config.h
- ${CMAKE_BINARY_DIR}/mcop # for arts_export.h
- ${CMAKE_SOURCE_DIR}/mcop # for common.h
- ${CMAKE_CURRENT_BINARY_DIR} # for gsl/gslconfig.h
- ${CMAKE_CURRENT_SOURCE_DIR} # for gsl/gsldefs.h
- ${GLIB2_INCLUDE_DIRS} # for glib.h
+##### headers ###################################
+
+install( FILES
+ audiosubsys.h cache.h cachedwav.h convert.h
+ pipebuffer.h stdsynthmodule.h synthschedule.h
+ fft.h artsflow.idl audioio.h resample.h cpuinfo.h
+ bufferqueue.h gslschedule.h
+ ${CMAKE_CURRENT_BINARY_DIR}/artsflow.h
+ DESTINATION ${INCLUDE_INSTALL_DIR} )
+
+
+##### artsflow (shared lib) #####################
+
+set( target artsflow )
+
+set( ${target}_SRCS
+ synth_play_impl.cc gslschedule.cc audiosubsys.cc
+ pipebuffer.cc convert.cc synth_wave_sin_impl.cc
+ synth_frequency_impl.cc synth_multi_add_impl.cc
+ synth_add_impl.cc synth_mul_impl.cc synth_play_wav_impl.cc
+ stdsynthmodule.cc cache.cc asyncschedule.cc bytestreamtoaudio_impl.cc
+ stereovolumecontrol_impl.cc stereoeffectstack_impl.cc
+ fft.c stereofftscope_impl.cc virtualports.cc bus.cc
+ audiomanager_impl.cc synth_record_impl.cc resample.cc
+ audioio.cc audioiooss.cc audioioalsa.cc audioioalsa9.cc
+ audioionull.cc audioiolibaudioio.cc audioioesd.cc
+ audioiojack.cc audioiosun.cc audioioaix.cc audioionas.cc
+ cpuinfo.cc audioioossthreaded.cc audiotobytestream_impl.cc
+ audioiosgi.cc audioiocsl.cc audioiomas.cc datahandle_impl.cc
)
-add_definitions(
- -DHAVE_CONFIG_H
+tde_add_library( ${target} SHARED
+ SOURCES ${${target}_SRCS}
+ VERSION 1.0.0
+ LINK gsl-static gslpp-static artsflow_idl-shared ${AUDIOFILE_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
)
-##### artsflow_idl
+##### artsflow_idl (shared lib) #################
add_custom_command(
OUTPUT artsflow.cc
@@ -97,28 +69,10 @@ add_custom_command(
ARGS -t ${CMAKE_CURRENT_SOURCE_DIR}/artsflow.idl DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/artsflow.idl
)
-set( artsflow_idl_SRCS artsflow.cc )
-add_library( artsflow_idl SHARED ${artsflow_idl_SRCS} )
-set_target_properties( artsflow_idl PROPERTIES VERSION 1.0 SOVERSION 1 )
-target_link_libraries( artsflow_idl mcop ${ALSA_LIBRARY} )
-add_dependencies( artsflow_idl mcopidl )
-
-##### artsflow
-
-add_library( artsflow SHARED ${artsflow_SRCS} )
-set_target_properties( artsflow PROPERTIES VERSION 1.0 SOVERSION 1 )
-
-target_link_libraries( artsflow
- artsflow_idl
- mcop
- gslpp
- gsl
- ${AUDIOFILE_LIBRARIES}
+tde_add_library( artsflow_idl SHARED
+ SOURCES artsflow.cc
+ VERSION 1.0.0
+ LINK mcop-shared ${ALSA_LIBRARY}
+ DESTINATION ${LIB_INSTALL_DIR}
+ DEPENDENCIES mcopidl
)
-
-
-
-##### install ###################################
-
-install( FILES ${artsflow_INCS} DESTINATION ${INCLUDE_INSTALL_DIR} )
-install( TARGETS artsflow_idl artsflow LIBRARY DESTINATION ${LIB_INSTALL_DIR} ) \ No newline at end of file