summaryrefslogtreecommitdiffstats
path: root/mcopidl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mcopidl/CMakeLists.txt')
-rw-r--r--mcopidl/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/mcopidl/CMakeLists.txt b/mcopidl/CMakeLists.txt
new file mode 100644
index 0000000..ea87893
--- /dev/null
+++ b/mcopidl/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+set( mcopidl_SRCS
+ mcopidl.cc
+ yacc.cc
+ scanner.cc
+ namespace.cc
+)
+
+include_directories(
+ ${CMAKE_BINARY_DIR}/mcop # for arts_export.h
+ ${CMAKE_SOURCE_DIR}/mcop # for common.h
+)
+
+#link_directories(
+# ${CMAKE_BINARY_DIR}/mcop
+#)
+
+add_executable( mcopidl ${mcopidl_SRCS} )
+target_link_libraries( mcopidl mcop )
+
+
+##### install ###################################
+
+install( TARGETS mcopidl DESTINATION ${BIN_INSTALL_DIR} )