summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-02-25 15:05:47 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-04-10 12:47:23 +0200
commitce133b3eda6bddc2750800d1bb76cf3c5a947daf (patch)
treee0f684a1d9d2f50918124dd0c163eaa1d8aba621 /doc/CMakeLists.txt
parentb51e232350d31b65a8cd055693c7869f0a896193 (diff)
downloadbasket-ce133b3eda6bddc2750800d1bb76cf3c5a947daf.tar.gz
basket-ce133b3eda6bddc2750800d1bb76cf3c5a947daf.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net> Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2578c13462d6ff5f6da401c62b24c461b3b445ca)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..70d6348
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _dir ${_dirs} )
+ if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}/CMakeLists.txt )
+ if( "${_dir}" STREQUAL "en" OR
+ "${_dir}" STREQUAL "man" OR
+ "${_linguas}" MATCHES "^;*$" OR
+ ";${_linguas};" MATCHES ";${_dir};" )
+ add_subdirectory( ${_dir} )
+ endif( )
+ endif()
+endforeach()