summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in217
1 files changed, 0 insertions, 217 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 646583c..0000000
--- a/configure.in
+++ /dev/null
@@ -1,217 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(basket, '1.0.3.1') dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_QT(3.0.0)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.0.0)
-
-dnl PACKAGE set before
-AC_C_BIGENDIAN
-AC_CHECK_KDEMAXPATHLEN
-
-KDE_CHECK_LARGEFILE
-
-dnl -----------------------------------------------------------------
-dnl AC_LIB_GPGME([ACTION-IF-TRUE], [ACTION-IF-FALSE])
-dnl -----------------------------------------------------------------
-
-OPTION=" --with-encryption=yes/no compile with encryption support (gpgme)"
-
-AC_DEFUN([AC_ENCRYPTION], [
- AH_TEMPLATE([HAVE_LIBGPGME], [Define if libgpgme is available])
-
- AC_ARG_WITH(encryption, [$OPTION], [
- if test "$withval" = "no"; then
- ac_gpg=
- $2
- elif test "$withval" = "yes"; then
- ac_gpg=yes
- else
- ac_gpg=yes
- fi
- ],[ac_gpg=yes])
-
- if test "$ac_gpg" != ""; then
- AM_PATH_GPGME(1.0.0, ac_libgpgme=yes, ac_libgpgme=no)
- AM_PATH_GPG_ERROR(1.0, ac_libgpgerror=yes, ac_libgpgerror=no)
-
- if test "$ac_libgpgme" != "no" -a "$ac_libgpgerror" != "no"; then
- AC_DEFINE([HAVE_LIBGPGME])
- ac_have_gpgme="yes"
- $1
- else
- :
- $2
- fi
- fi
- AM_CONDITIONAL(HAVE_LIBGPGME, test "$ac_have_gpgme" = "yes")
-])
-
-AC_ENCRYPTION([], [basket_warning_gpgme=yes])
-
-KDE_CHECK_HEADER(kontact/core.h, [KONTACT_SUBDIR="yes"], [KONTACT_SUBDIR="no"])
-
-if test "$KONTACT_SUBDIR" = "no"; then
- basket_warning_kontact=yes
- DO_NOT_COMPILE="$DO_NOT_COMPILE kontact_plugin"
-fi
-
-KDE_CREATE_SUBDIRSLIST
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ backgrounds/Makefile ])
-AC_CONFIG_FILES([ backgrounds-previews/Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/en/Makefile ])
-AC_CONFIG_FILES([ file-integration/Makefile ])
-AC_CONFIG_FILES([ images/Makefile ])
-AC_CONFIG_FILES([ kontact_plugin/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-AC_CONFIG_FILES([ src/Makefile ])
-AC_CONFIG_FILES([ tags/Makefile ])
-AC_CONFIG_FILES([ welcome/Makefile ])
-AC_OUTPUT
-# configure.in.bot
-# This file is used for printing important messages at the end of configure
-
-echo ""
-
-if test x$basket_warning_gpgme = xyes; then
- echo " ===================================="
- echo " === BasKet Note Pads - WARNING ==================================="
- echo " ===================================="
- echo " ="
- echo " = BasKet Note Pads requires gpgme version 1.0 and"
- echo " = libgpg-error version 1.0."
- echo " = BasKet Note Pads will still be built, but there is no encryption."
- echo " ="
- echo " = Packages you need to install if you want encryption:"
- echo " = Suse: gpgme-devel"
- echo " = Kubuntu: libgpgme11-dev"
- echo " = Fedora Core: gpgme-devel"
- echo " = Mandriva: libgpgme11-devel"
- echo " = Gentoo: app-crypt/gpgme"
- echo " ="
-fi
-
-if test x$basket_warning_kontact = xyes; then
- echo " ===================================="
- echo " === BasKet Note Pads - WARNING ==================================="
- echo " ===================================="
- echo " ="
- echo " = BasKet Note Pads requires tdepim."
- echo " = BasKet Note Pads will still be built, but there is no"
- echo " = Kontact integration."
- echo " ="
- echo " = Packages you need to install if you want Kontact integration:"
- echo " = Suse: tdepim3-devel"
- echo " = Kubuntu: tdepim-dev"
- echo " = Fedora Core: tdepim-devel"
- echo " = Mandriva: libtdepim2-common-devel & libtdepim2-kontact-devel"
- echo " = Gentoo: kde-base/kontact"
- echo " ="
-fi
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi