summaryrefslogtreecommitdiffstats
path: root/src/libs/thumbbar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/thumbbar/Makefile.am')
-rw-r--r--src/libs/thumbbar/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/libs/thumbbar/Makefile.am b/src/libs/thumbbar/Makefile.am
new file mode 100644
index 00000000..7e885514
--- /dev/null
+++ b/src/libs/thumbbar/Makefile.am
@@ -0,0 +1,18 @@
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libthumbbar.la
+
+libthumbbar_la_SOURCES = thumbbar.cpp thumbnailjob.cpp
+
+libthumbbar_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+INCLUDES = -I$(top_srcdir)/src/libs/dimg \
+ -I$(top_srcdir)/src/libs/dmetadata \
+ -I$(top_srcdir)/src/digikam \
+ $(LIBKDCRAW_CFLAGS) \
+ $(LIBKEXIV2_CFLAGS) \
+ $(all_includes)
+
+digikaminclude_HEADERS = thumbbar.h
+
+digikamincludedir = $(includedir)/digikam