summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:53:59 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 15:43:37 +0900
commitf0b27130491362231de1957ca92e6724c19d0f47 (patch)
tree8046e5d984355c1456c3afb3551b59432032f192 /CMakeLists.txt
parent843bdb504463df9cc80caea6cf6ac7e27bacfb04 (diff)
downloadgwenview-f0b27130491362231de1957ca92e6724c19d0f47.tar.gz
gwenview-f0b27130491362231de1957ca92e6724c19d0f47.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 6d6d0adfe0d983da2678d624595f8a2afcaca2e3)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e216c60..2f09482 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ enable_testing()
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )