summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-04-06 16:39:59 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-04-07 20:39:49 +0200
commit77208228c9f7c77d5d2c65f56def2fe8b31b530d (patch)
treeac3447df80e47c5dd8dd930ee20c6f75ce2712f1 /CMakeLists.txt
parent0dd82949730ce8e907711ad43b81a2c3923e5d1b (diff)
downloadkcmldapcontroller-77208228c9f7c77d5d2c65f56def2fe8b31b530d.tar.gz
kcmldapcontroller-77208228c9f7c77d5d2c65f56def2fe8b31b530d.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit fd16b3640527b9da8e1df97f5e25849e0313ac64)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1357957..637a17c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,8 +70,8 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
-
+add_definitions( -DHAVE_CONFIG_H )
+
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )