summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMavridis Philippe <mavridisf@gmail.com>2021-01-13 19:34:09 +0200
committerMavridis Philippe <mavridisf@gmail.com>2021-01-13 19:34:09 +0200
commit4c04a441814c7d1dda08f6075ab4e09dc05541df (patch)
treecf8a3dbd77114c416255d3995cd1b047072ef26a /configure.in
parent357ddeb8afd82d69ef871c146f4fc8f2c67fb17e (diff)
downloadklamav-4c04a441814c7d1dda08f6075ab4e09dc05541df.tar.gz
klamav-4c04a441814c7d1dda08f6075ab4e09dc05541df.zip
Conversion KDE3->TDE
Signed-off-by: Mavridis Philippe <mavridisf@gmail.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index dcf329a..5d7fc33 100644
--- a/configure.in
+++ b/configure.in
@@ -123,13 +123,13 @@ AC_MSG_CHECKING([for KDE version])
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-kdeversion_save_CXXFLAGS="$CXXFLAGS"
-kdeversion_safe_LIBS="$LIBS"
+tdeversion_save_CXXFLAGS="$CXXFLAGS"
+tdeversion_safe_LIBS="$LIBS"
LIBS="$LIBS $X_EXTRA_LIBS"
CXXFLAGS="$CXXFLAGS $all_includes"
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 2, 90 ) )
#error KDE 3.2
#endif
@@ -140,7 +140,7 @@ AC_COMPILE_IFELSE([
)
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 3, 90 ) )
#error KDE 3.3
#endif
@@ -151,7 +151,7 @@ AC_COMPILE_IFELSE([
)
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 4, 90 ) )
#error KDE 3.4
#endif
@@ -162,7 +162,7 @@ AC_COMPILE_IFELSE([
)
AC_COMPILE_IFELSE([
-#include <kdeversion.h>
+#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 5, 2 ) )
#error KDE 3.5.x (x < 2)
#endif
@@ -171,8 +171,8 @@ AC_COMPILE_IFELSE([
,
need_kde351_compat="yes"
)
-CXXFLAGS="$kdeversion_save_CXXFLAGS"
-LIBS="$kdeversion_safe_LIBS"
+CXXFLAGS="$tdeversion_save_CXXFLAGS"
+LIBS="$tdeversion_safe_LIBS"
AC_LANG_RESTORE
if test "$need_kde32_compat" = "yes"; then
@@ -243,13 +243,13 @@ if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
# And if so, warn when they don't match
if test "$kde_libs_prefix" != "$given_prefix"; then
# And if kde doesn't know about the prefix yet
- echo ":"`kde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
+ echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
if test $? -ne 0; then
echo ""
echo "Warning: you chose to install this package in $given_prefix,"
echo "but KDE was found in $kde_libs_prefix."
echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that KDEDIRS contains it, e.g. export KDEDIRS=$given_prefix:$kde_libs_prefix"
+ echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
echo "Then restart KDE."
echo ""
fi