summaryrefslogtreecommitdiffstats
path: root/KMFIPTInterface/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'KMFIPTInterface/Makefile.am')
-rw-r--r--KMFIPTInterface/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/KMFIPTInterface/Makefile.am b/KMFIPTInterface/Makefile.am
new file mode 100644
index 0000000..c8b96ab
--- /dev/null
+++ b/KMFIPTInterface/Makefile.am
@@ -0,0 +1,17 @@
+bin_PROGRAMS = kmfiptinterface
+INCLUDES = $(all_includes)
+kmfiptinterface_LDFLAGS = -module $(all_libraries) $(KDE_RPATH)
+kmfiptinterface_LDADD = $(LIB_KIO)
+kmfiptinterface_SOURCES = main.cpp kmfiptinterface.cpp iptchecker.cpp kmfiptinterface.skel
+
+
+noinst_HEADERS = kmfiptinterface.h iptchecker.h
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/dcoptest.pot
+
+
+service_DATA = kmfiptinterface.desktop
+servicedir = $(kde_servicesdir)