summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-20 15:27:05 +0100
committergregory guy <gregory-tde@laposte.net>2020-03-20 15:34:34 +0100
commit9de1ae68cda942c5455f5ca3a1f52539d82a57c2 (patch)
tree137f3336fc5df41c42e865ee9b88edaaf68b4c34 /CMakeLists.txt
parent22deb64ecae982864daff36d5317eee7d3de53f7 (diff)
downloadknowit-9de1ae68cda942c5455f5ca3a1f52539d82a57c2.tar.gz
knowit-9de1ae68cda942c5455f5ca3a1f52539d82a57c2.zip
Drop automake build support.
Delete the templates folder. Add basic build instructions. Rework of the README and help page. Some Cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 878851b..e95c583 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,8 +69,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files