summaryrefslogtreecommitdiffstats
path: root/tools/kfile-plugins/abiword/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-06-13 08:37:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2012-06-13 08:37:52 +0200
commit5c69fcd39111465de16c933763d3c918703048d8 (patch)
treeccd0a0cf7e7d30a8ebe16a71e7e26ede6ee7a66c /tools/kfile-plugins/abiword/Makefile.am
parent17477649bd724528a78e6c772244dc1a63f38202 (diff)
downloadkoffice-5c69fcd39111465de16c933763d3c918703048d8.tar.gz
koffice-5c69fcd39111465de16c933763d3c918703048d8.zip
Fix FTBFS due to missing libraries
Clean up lib paths in LDFLAGS - moved to LIBADD For KWord and and KPresenter added linking kspell2 For KSpread added linking kutils This closes Bug 657
Diffstat (limited to 'tools/kfile-plugins/abiword/Makefile.am')
-rw-r--r--tools/kfile-plugins/abiword/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/kfile-plugins/abiword/Makefile.am b/tools/kfile-plugins/abiword/Makefile.am
index efeee86f..81e8a65c 100644
--- a/tools/kfile-plugins/abiword/Makefile.am
+++ b/tools/kfile-plugins/abiword/Makefile.am
@@ -9,8 +9,8 @@ noinst_HEADERS = kfile_abiword.h
kde_module_LTLIBRARIES = kfile_abiword.la
kfile_abiword_la_SOURCES = kfile_abiword.cpp
-kfile_abiword_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts -L../../../lib/kofficecore/.libs/ -lkofficecore -L../../../lib/kofficeui/.libs/ -lkofficeui -L../../../lib/store/.libs/ -lkstore
-kfile_abiword_la_LIBADD = $(LIB_KOFFICECORE)
+kfile_abiword_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -lkio -lkparts
+kfile_abiword_la_LIBADD = $(KOFFICE_LIBS)
# let automoc handle all of the meta source files (moc)
METASOURCES = AUTO