summaryrefslogtreecommitdiffstats
path: root/lib/kofficecore/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kofficecore/tests/Makefile.am')
-rw-r--r--lib/kofficecore/tests/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/lib/kofficecore/tests/Makefile.am b/lib/kofficecore/tests/Makefile.am
new file mode 100644
index 00000000..3cc6827a
--- /dev/null
+++ b/lib/kofficecore/tests/Makefile.am
@@ -0,0 +1,40 @@
+####### General stuff
+
+INCLUDES= -I$(srcdir)/.. $(KSTORE_INCLUDES) $(all_includes)
+
+####### Files
+
+check_PROGRAMS = priorityqueue_test filterchain_test filter_graph kogenstylestest \
+ kodomtest kooasissettingstest kooasisstoretest kopointtest korecttest
+
+TESTS = kogenstylestest kodomtest kooasissettingstest kooasisstoretest kopointtest korecttest
+
+priorityqueue_test_SOURCES = priorityqueue_test.cpp
+priorityqueue_test_LDADD = ../libkofficecore.la
+
+filterchain_test_SOURCES = filterchain_test.cpp
+filterchain_test_LDADD = ../libkofficecore.la
+
+filter_graph_SOURCES = filter_graph.cpp
+filter_graph_LDADD = ../libkofficecore.la
+
+kogenstylestest_SOURCES = kogenstylestest.cpp
+kogenstylestest_LDADD = ../libkofficecore.la
+
+kodomtest_SOURCES = kodomtest.cpp
+kodomtest_LDADD = ../libkofficecore.la
+
+kooasissettingstest_SOURCES = kooasissettingstest.cpp
+kooasissettingstest_LDADD = ../libkofficecore.la
+
+kooasisstoretest_SOURCES = kooasisstoretest.cpp
+kooasisstoretest_LDADD = ../libkofficecore.la
+
+kopointtest_SOURCES = kopointtest.cpp
+kopointtest_LDADD = ../libkofficecore.la
+
+korecttest_SOURCES = korecttest.cpp
+korecttest_LDADD = ../libkofficecore.la
+
+dot:
+ dot -Tpng -o graph.png graph.dot