summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c6514a3
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,50 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kommando.h roundbutton.h commandobutton.h menu.h \
+ configdialogimpl.h menulistviewitem.h configuration.h servicemenu.h kommandoview.h \
+ kommandod.h kcmkommando.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kommando.pot
+
+KDE_ICON = AUTO
+
+#########################################################################
+# SHARED LIBRARY
+#########################################################################
+
+lib_LTLIBRARIES = libkommando.la
+libkommando_la_SOURCES = menulistviewitem.cpp configuration.cpp menu.cpp \
+ commandobutton.cpp roundbutton.cpp kommandoview.cpp
+libkommando_la_LDFLAGS = -version-info 1:0:0 $(all_libraries)
+libkommando_la_LIBADD = $(LIB_KDECORE)
+
+#########################################################################
+# KDE MODULES SECTION
+#########################################################################
+# this is the library that gets installed. it's name is used for all
+# of the other Makefile.am variables
+kde_module_LTLIBRARIES = kded_kommandod.la kcm_kommando.la
+
+kded_kommandod_la_SOURCES = kommandod.cpp kommandod.skel kommando.cpp
+kded_kommandod_la_METASOURCES = AUTO
+kded_kommandod_la_LDFLAGS = -avoid-version -module $(all_libraries)
+kded_kommandod_la_LIBADD = -lXmu libkommando.la $(LIB_KDECORE)
+
+servicesdir = $(kde_servicesdir)/kded
+services_DATA = kommandod.desktop
+
+kcm_kommando_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+kcm_kommando_la_SOURCES = configdialogimpl.cpp configdialog.ui \
+ kcmkommando.cpp servicemenu.cpp
+kcm_kommando_la_LIBADD = libkommando.la -lXmu $(LIB_KIO) $(LIB_KDEUI) \
+ $(LIB_KDECORE)
+
+# this is where the desktop file will go
+xdg_apps_DATA = kommando.desktop