summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMavridis Philippe <mavridisf@gmail.com>2021-03-30 13:58:33 +0300
committerMavridis Philippe <mavridisf@gmail.com>2021-03-30 13:58:33 +0300
commit74b22318b8df6c1e9355b73a16bb755a5178b8d6 (patch)
tree538c9e62d606c6718fa64f8c8f2ad42e4aefc1ad /src/Makefile.am
downloadkompose-74b22318b8df6c1e9355b73a16bb755a5178b8d6.tar.gz
kompose-74b22318b8df6c1e9355b73a16bb755a5178b8d6.zip
Initial commit (KDE3 version)
Signed-off-by: Mavridis Philippe <mavridisf@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..77d2354
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,46 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes) -I `imlib2-config --cflags`
+
+# these are the headers for your project
+noinst_HEADERS = kompose.h komposetaskmanager.h komposetask.h komposewidget.h \
+ komposetaskwidget.h komposedesktopwidget.h komposelayout.h komposesystray.h \
+ komposefullscreenwidget.h komposesettings.h komposepreferences.h komposetaskprefswidget.h \
+ komposeglobal.h komposetaskcontainerwidget.h komposetaskvisualizer.h \
+ komposeviewmanager.h komposedcopiface.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp --language=C --from-code=UTF-8 -o $(podir)/kompose.pot
+
+komposeiconsdir = $(kde_datadir)/kompose/icons
+komposeicons_ICON = AUTO
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kompose
+
+# the application source, library search path, and link libraries
+kompose_SOURCES = main.cpp kompose.cpp komposetaskmanager.cpp komposetask.cpp \
+ komposewidget.cpp komposetaskwidget.cpp komposedesktopwidget.cpp komposelayout.cpp \
+ komposesystray.cpp komposefullscreenwidget.cpp komposesettings.cpp komposepreferences.cpp \
+ komposetaskprefswidget.cpp komposeglobal.cpp komposetaskcontainerwidget.cpp \
+ komposetaskvisualizer.cpp komposeviewmanager.cpp komposedcopiface.skel
+#kompose_LDFLAGS = $(KDE_RPATH) $(all_libraries) -lX11 -lXext -lm `pkg-config xft xrender xcomposite xdamage xfixes --libs` `imlib2-config --libs`
+kompose_LDFLAGS = $(KDE_RPATH) $(all_libraries) -lX11 -lXext -lm `imlib2-config --libs`
+kompose_LDADD = $(LIB_KDEUI) $(LIB_XCOMPOSITE) $(LIB_XDAMAGE)
+
+# this is where the desktop file will go
+shelldesktopdir = $(kde_appsdir)/Utilities
+shelldesktop_DATA = kompose.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/kompose
+shellrc_DATA = komposeui.rc
+
+
+