summaryrefslogtreecommitdiffstats
path: root/conduits/memofileconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/memofileconduit/CMakeLists.txt
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/memofileconduit/CMakeLists.txt')
-rw-r--r--conduits/memofileconduit/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/conduits/memofileconduit/CMakeLists.txt b/conduits/memofileconduit/CMakeLists.txt
new file mode 100644
index 0000000..5699457
--- /dev/null
+++ b/conduits/memofileconduit/CMakeLists.txt
@@ -0,0 +1,44 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+set(conduit_memofile_SRCS
+ memofile-factory.cc
+ memofile.cc
+ memofiles.cc
+ memofile-conduit.cc
+)
+
+set(conduit_memofile_UIS
+ setup_base.ui
+)
+
+set(conduit_memofile_KCFGS
+ memofileSettings.kcfgc
+)
+
+kde3_add_kcfg_files(conduit_memofile_SRCS ${conduit_memofile_KCFGS})
+kde3_add_ui_files(conduit_memofile_SRCS ${conduit_memofile_UIS})
+kde3_automoc(${conduit_memofile_SRCS})
+add_library(conduit_memofile SHARED ${conduit_memofile_SRCS})
+
+set_target_properties(
+ conduit_memofile PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib
+ PREFIX ""
+)
+
+kde3_install_libtool_file(conduit_memofile)
+
+install(
+ TARGETS conduit_memofile
+ LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
+)
+
+install(
+ FILES memofile-conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
+)
+
+install(
+ FILES memofileconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
+)