summaryrefslogtreecommitdiffstats
path: root/extras/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-02 17:50:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-02 17:51:17 +0200
commitbf18769c595215fa138ff23b9bd115bc238b99b9 (patch)
treea1af73b9258cb11c6718f0815cfb558176cd908d /extras/CMakeLists.txt
parent3626b53227439960175160da61ea3cdb8cf9827b (diff)
downloadkshutdown-bf18769c595215fa138ff23b9bd115bc238b99b9.tar.gz
kshutdown-bf18769c595215fa138ff23b9bd115bc238b99b9.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 973ccd2d158a63ad581504ab32fdae872e57cbfd)
Diffstat (limited to 'extras/CMakeLists.txt')
-rw-r--r--extras/CMakeLists.txt17
1 files changed, 10 insertions, 7 deletions
diff --git a/extras/CMakeLists.txt b/extras/CMakeLists.txt
index 4645d0a..848ccff 100644
--- a/extras/CMakeLists.txt
+++ b/extras/CMakeLists.txt
@@ -1,8 +1,11 @@
-add_subdirectory( multimedia )
-add_subdirectory( shutdown )
-add_subdirectory( system )
+file( GLOB _files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} .directory *.desktop )
-install(
- FILES hibernate.desktop
- DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras
-)
+foreach( _source ${_files} )
+ tde_create_translated_desktop(
+ SOURCE ${_source}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/extras
+ )
+endforeach()
+
+tde_auto_add_subdirectories( )