summaryrefslogtreecommitdiffstats
path: root/extras/system/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-02 17:50:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-02 17:50:07 +0200
commit973ccd2d158a63ad581504ab32fdae872e57cbfd (patch)
treef1e6a4cb0763e57458c5fb6c86be2dc01e8ef492 /extras/system/CMakeLists.txt
parent761db40024a2195b2ab3f19357db8b236e25ad56 (diff)
downloadkshutdown-973ccd2d158a63ad581504ab32fdae872e57cbfd.tar.gz
kshutdown-973ccd2d158a63ad581504ab32fdae872e57cbfd.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'extras/system/CMakeLists.txt')
-rw-r--r--extras/system/CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/extras/system/CMakeLists.txt b/extras/system/CMakeLists.txt
index 6e6e107..a2d7e6d 100644
--- a/extras/system/CMakeLists.txt
+++ b/extras/system/CMakeLists.txt
@@ -1,6 +1,9 @@
-file( GLOB _files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.desktop )
+file( GLOB _files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} .directory *.desktop )
-install(
- FILES ${_files} .directory
- DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras/system
-)
+foreach( _source ${_files} )
+ tde_create_translated_desktop(
+ SOURCE ${_source}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras/system
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/extras
+ )
+endforeach()