summaryrefslogtreecommitdiffstats
path: root/extras/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'extras/CMakeLists.txt')
-rw-r--r--extras/CMakeLists.txt17
1 files changed, 10 insertions, 7 deletions
diff --git a/extras/CMakeLists.txt b/extras/CMakeLists.txt
index 4645d0a..848ccff 100644
--- a/extras/CMakeLists.txt
+++ b/extras/CMakeLists.txt
@@ -1,8 +1,11 @@
-add_subdirectory( multimedia )
-add_subdirectory( shutdown )
-add_subdirectory( system )
+file( GLOB _files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} .directory *.desktop )
-install(
- FILES hibernate.desktop
- DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras
-)
+foreach( _source ${_files} )
+ tde_create_translated_desktop(
+ SOURCE ${_source}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/extras
+ )
+endforeach()
+
+tde_auto_add_subdirectories( )