summaryrefslogtreecommitdiffstats
path: root/plugins/search/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
commit9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0 (patch)
treed088b5210e77d9fa91d954d8550e00e372b47378 /plugins/search/Makefile.am
downloadktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.tar.gz
ktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.zip
Updated to final KDE3 ktorrent release (2.2.6)
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/ktorrent@1077377 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'plugins/search/Makefile.am')
-rw-r--r--plugins/search/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/search/Makefile.am b/plugins/search/Makefile.am
new file mode 100644
index 0000000..af57f30
--- /dev/null
+++ b/plugins/search/Makefile.am
@@ -0,0 +1,28 @@
+INCLUDES = -I$(srcdir)/../../libktorrent $(all_includes)
+METASOURCES = AUTO
+kde_module_LTLIBRARIES = ktsearchplugin.la
+noinst_HEADERS = searchplugin.h searchprefpage.h searchtab.h searchenginelist.h
+ktsearchplugin_la_SOURCES = searchplugin.cpp htmlpart.cpp searchbar.ui \
+ searchpref.ui searchwidget.cpp searchprefpage.cpp searchpluginsettings.kcfgc \
+ searchtab.cpp searchenginelist.cpp
+
+# Libs needed by the plugin
+ktsearchplugin_la_LIBADD = ../../libktorrent/libktorrent.la \
+ $(LIB_KHTML) $(LIB_KPARTS) $(LIB_QT) \
+ $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE)
+
+# LD flags for the plugin
+# -module says: this is a module, i.e. something you're going to dlopen
+# so e.g. it has no version number like a normal shared lib would have.
+ktsearchplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+# rc file containing the GUI for the plugin
+# pluginsdir = $(kde_datadir)/ktsearchplugin
+# plugins_DATA = ktsearchpluginui.rc
+
+# Install the desktop file needed to detect the plugin
+kde_services_DATA = ktsearchplugin.desktop
+
+kde_kcfg_DATA = ktsearchplugin.kcfg
+
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)