summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8381445..3263f34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,6 +157,8 @@ check_include_file("sys/types.h" HAVE_SYS_TYPES_H)
check_function_exists(gettimeofday LIBVNCSERVER_HAVE_GETTIMEOFDAY)
check_function_exists(vfork LIBVNCSERVER_HAVE_VFORK)
check_function_exists(vprintf LIBVNCSERVER_HAVE_VPRINTF)
+check_function_exists(mmap LIBVNCSERVER_HAVE_MMAP)
+check_function_exists(fork LIBVNCSERVER_HAVE_FORK)
# On systems such as GNU/Linux with glibc, __b64_ntop is defined in a
@@ -230,6 +232,9 @@ if(WITH_GCRYPT AND LIBGCRYPT_LIBRARIES)
set(ADDITIONAL_LIBS ${ADDITIONAL_LIBS} ${LIBGCRYPT_LIBRARIES})
endif(WITH_GCRYPT AND LIBGCRYPT_LIBRARIES)
+if(OPENSSL_FOUND)
+ set(LIBVNCSERVER_HAVE_LIBSSL 1)
+endif(OPENSSL_FOUND)
if(WITH_IPv6)
if(WIN32 AND LIBVNCSERVER_HAVE_WS2TCPIP_H AND LIBVNCSERVER_HAVE_VPRINTF)