summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1ca7941..33839d5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,6 +1,13 @@
-CFLAGS=-I.. -g -Wall
+DEFINES=-I.. -g -Wall
+
+if HAVE_LIBPTHREAD
+BACKGROUND_TEST=blooptest
+endif
+
+copyrecttest_LDADD=$(LDADD) -lm
+
+noinst_PROGRAMS=tight-1 cargstest copyrecttest $(BACKGROUND_TEST)
-noinst_PROGRAMS=tight-1 cargstest
LDADD = ../libvncserver/libvncserver.a ../libvncclient/libvncclient.a