summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-12-19 20:05:06 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-12-19 20:08:46 +0900
commitab12cfe230b06ba2a4505e681d7b8ce6ea35fb34 (patch)
treea6bb5fc600136016a2e3fd309ce6b3ad8a6c7cc9 /src/CMakeLists.txt
parent796d4dc1ab15ce7f898d3fc0014e4b64a0be155d (diff)
downloadpolkit-agent-tde-ab12cfe230b06ba2a4505e681d7b8ce6ea35fb34.tar.gz
polkit-agent-tde-ab12cfe230b06ba2a4505e681d7b8ce6ea35fb34.zip
Updated cmake files to allow building the package, although it is just a dummy package (not functional).
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..0f1b794
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2021 Michele Calgaro
+# Michele (DOT) Calgaro (AT) yahoo.it
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### executables #########################
+
+tde_add_executable( polkit-agent-tde AUTOMOC
+ SOURCES main.cpp
+ LINK tdecore-shared tdeui-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)