summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoraneejit1 <aneejit1@gmail.com>2020-06-26 03:50:20 +0000
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-06-26 07:09:25 +0000
commitc8a78967418076d582f1307bed79439bf18bf68b (patch)
tree4c5c907c592b88e44501e6a49c93d77cdaf1078e /CMakeLists.txt
parent18f1a4426d01f6ad81f248c61612cc2b78d19ad5 (diff)
downloadrosegarden-c8a78967418076d582f1307bed79439bf18bf68b.tar.gz
rosegarden-c8a78967418076d582f1307bed79439bf18bf68b.zip
Write version.txt and rosegarden.spec to the binary directory
Signed-off-by: aneejit1 <aneejit1@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f10008a..8fc581b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,8 +116,8 @@ tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
configure_file( config.h.cmake config.h @ONLY )
# create and install the version file
-FILE(WRITE version.txt "${VERSION}\n")
-INSTALL( FILES version.txt DESTINATION ${DATA_INSTALL_DIR}/rosegarden )
+FILE(WRITE "${CMAKE_BINARY_DIR}/version.txt" "${VERSION}\n")
+INSTALL( FILES "${CMAKE_BINARY_DIR}/version.txt" DESTINATION ${DATA_INSTALL_DIR}/rosegarden )
# configure the RPM spec
-CONFIGURE_FILE("${CMAKE_SOURCE_DIR}/rosegarden.spec.in" "${CMAKE_SOURCE_DIR}/rosegarden.spec" IMMEDIATE @ONLY) \ No newline at end of file
+CONFIGURE_FILE("${CMAKE_SOURCE_DIR}/rosegarden.spec.in" "${CMAKE_BINARY_DIR}/rosegarden.spec" IMMEDIATE @ONLY)