summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..474ac2d
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,43 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### smartauthckpasswd (executable)
+
+tde_add_executable( smartauthckpasswd
+
+ SOURCES
+ ckpasswd.c
+ xmalloc.c
+ messages.c
+ LINK
+ ${CRYPT_LIBRARY}
+ ${PAM_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### smartauthmon (executable)
+
+tde_add_executable( smartauthmon
+
+ SOURCES
+ smartauthmon.cpp
+ ckpass.c
+ xmalloc.c
+ messages.c
+ LINK
+ ${CRYPT_LIBRARY}
+ ${PAM_LIBRARIES}
+ ${TQT_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)