summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-13 05:43:39 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-13 05:43:39 +0000
commit19ae07d0d443ff8b777f46bcbe97119483356bfd (patch)
treedae169167c23ba7c61814101995de21d6abac2e8 /Makefile.am
downloadtde-guidance-19ae07d0d443ff8b777f46bcbe97119483356bfd.tar.gz
tde-guidance-19ae07d0d443ff8b777f46bcbe97119483356bfd.zip
Added KDE3 version of KDE Guidance utilities
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kde-guidance@1102646 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ddb0573
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+messagesold:
+ LIST=`find . -name \*.py`; \
+ if test -n "$$LIST"; then \
+ xgettext -ki18n -LPython $$LIST -o po/guidance.pot; \
+ fi
+
+ sh /usr/lib/kubuntu-desktop-i18n/findfiles LIST
+ perl /usr/lib/kubuntu-desktop-i18n/createdesktop.pl --file-list=LIST --base-dir=. > desktop.guidance.tmp
+ msguniq --to-code=UTF-8 --no-wrap -o desktop.guidance desktop.guidance.tmp 2>/dev/null
+ python /usr/lib/kubuntu-desktop-i18n/msgsplit desktop.guidance
+ mv desktop.guidance po/desktop_guidance.pot
+ rm -f desktop.guidance desktop.guidance.tmp
+
+messages:
+ true