summaryrefslogtreecommitdiffstats
path: root/trinity-apps
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-30 16:26:06 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-05-02 12:42:28 +0000
commitffde2042a0595a8bd6e421c94ed74284eba05c82 (patch)
tree5f1791448e4b4d87673747324e5e34b7fc4e97bf /trinity-apps
parentd877f9249e915ae9b13282628e8670a8cb684a96 (diff)
downloadtde-packaging-gentoo-ffde2042a0595a8bd6e421c94ed74284eba05c82.tar.gz
tde-packaging-gentoo-ffde2042a0595a8bd6e421c94ed74284eba05c82.zip
Live ebuilds: Add `Akode` ebuild + Akode support for `Amarok`.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps')
-rw-r--r--trinity-apps/amarok/amarok-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/trinity-apps/amarok/amarok-9999.ebuild b/trinity-apps/amarok/amarok-9999.ebuild
index b08f9f75..f0eebbc5 100644
--- a/trinity-apps/amarok/amarok-9999.ebuild
+++ b/trinity-apps/amarok/amarok-9999.ebuild
@@ -7,10 +7,10 @@ TRINITY_MODULE_TYPE="applications"
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
-TRINITY_LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
-fr ga gl he hi hu id is it ja ka km ko ku lo lt mk ms nb nds ne nl nn pa
-pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn ss sv ta tg th tr uk uz uz@cyrillic
-zh_CN zh_TW"
+TRINITY_LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es
+ et eu fa fi fr ga gl he hi hu id is it ja ka km ko ku lo lt mk
+ ms nb nds ne nl nn pa pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn
+ ss sv ta tg th tr uk uz uz@cyrillic zh_CN zh_TW"
TRINITY_DOC_LANGS="da de es et fr it nl pl pt pt_BR ru sv"
@@ -26,9 +26,9 @@ SLOT="${TRINITY_VER}"
# Notes about the ebuild:
#
-# - This version supports three engines: Xine, Yauap, and Akode. The only one in
-# the portage tree at the moment is Xine. Akode is still maintained by Trinity,
-# so it's a possibility, but Yauap isn't in portage tree, but could be added later.
+# - This version supports three engines: Xine, Yauap, and Akode.
+# The only ones supported at the moment are Xine and Akode.
+# Yauap isn't in Portage tree, but could be added later.
#
# - Rio Karma support needs libkarma which neeeds to be added to our overlay later.
#
@@ -39,15 +39,16 @@ SLOT="${TRINITY_VER}"
# - Otherwise the ebuild should offer all what can be done with CMake at the moment.
IUSE+=" konqsidebar +xine ipod riokarma ifp njb mtp mp4
- inotify visualization amazon mysql postgres opengl"
+ inotify visualization amazon mysql postgres opengl akode"
-REQUIRED_USE="xine"
+REQUIRED_USE="|| ( xine akode )"
DEPEND+="
dev-lang/ruby:*
media-libs/taglib
- <media-libs/xine-lib-1.2.10
dev-db/sqlite
+ xine? ( <media-libs/xine-lib-1.2.10 )
+ akode? ( =media-libs/akode-${PV} )
mp4? ( media-libs/libmp4v2 )
ipod? ( media-libs/libgpod )
riokarma? ( media-libs/libkarma )
@@ -69,6 +70,7 @@ src_configure() {
-DWITH_AMAZON="$(usex amazon)"
-DWITH_KONQSIDEBAR="$(usex konqsidebar)"
-DWITH_XINE="$(usex xine)"
+ -DWITH_AKODE="$(usex akode)"
-DWITH_IPOD="$(usex ipod)"
-DWITH_RIOKARMA="$(usex riokarma)"
-DWITH_IFP="$(usex ifp)"
@@ -82,7 +84,6 @@ src_configure() {
-DWITH_POSTGRESQL="$(usex postgres)"
-DWITH_SYSTEM_SQLITE=ON
-DWITH_YAUAP=OFF
- -DWITH_AKODE=OFF
-DWITH_DAAP=OFF
)