summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop/kdesktop-14.0.12.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-base/kdesktop/kdesktop-14.0.12.ebuild
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kdesktop/kdesktop-14.0.12.ebuild')
-rw-r--r--trinity-base/kdesktop/kdesktop-14.0.12.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/trinity-base/kdesktop/kdesktop-14.0.12.ebuild b/trinity-base/kdesktop/kdesktop-14.0.12.ebuild
new file mode 100644
index 00000000..b57c0d45
--- /dev/null
+++ b/trinity-base/kdesktop/kdesktop-14.0.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="kcheckpass/ translations/ FindXscreensaver.cmake"
+inherit trinity-meta-2
+
+DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="pam xscreensaver hwlib"
+
+COMMON_DEPEND="
+ ~dev-libs/dbus-1-tqt-${PV}
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/libkonq-${PV}
+ x11-libs/libXrender
+ x11-libs/libXcursor
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+DEPEND="${COMMON_DEPEND}
+ xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
+RDEPEND="${COMMON_DEPEND}
+ ~trinity-base/kcheckpass-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/konqueror-${PV}
+ pam? ( trinity-base/tdebase-pam )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ -DWITH_XRENDER=ON
+ -DWITH_PAM="$(usex pam)"
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ -DTDESCREENSAVER_PAM_SERVICE=tde
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ )
+ trinity-meta-2_src_configure
+}