summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/kdesktop
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kdesktop')
-rw-r--r--trinity-base/kdesktop/Manifest1
-rw-r--r--trinity-base/kdesktop/kdesktop-14.0.11.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/trinity-base/kdesktop/Manifest b/trinity-base/kdesktop/Manifest
index 36fd9633..fc5248d9 100644
--- a/trinity-base/kdesktop/Manifest
+++ b/trinity-base/kdesktop/Manifest
@@ -1 +1,2 @@
+DIST tdebase-trinity-14.0.11.tar.xz 30554508 BLAKE2B f276a566f5cfd2ab66969209bdb0b273ce690c6ad6f12e869440e69f86ff7a6dc638aee6f2057c063796f87a30021896d152ebbcfb3f6b10958d0b759cff88dd SHA512 bd2894d07d8e03cc14f4ef0d99661aeb02d5a7b112ef007e758c926431587bfa9595ab477ec79c87ba2b5c5af36dfb3cd665faaa04a75f16eeab27a115874b1e
DIST tdebase-trinity-14.0.8.tar.xz 30049464 BLAKE2B c5a9a9c79cc12c8a9e85fb1913f334a208609c452fe150ade62bee5798e61abd956512f10059c215e7f7e07182dfbc1f3017600466598f85d9137689a7d0126e SHA512 e52ed05b416bb29b4a8d742bdcd908f5887d06aa7a64d2a1218a603a0926098504c0f1ef6de41552070ce1e5e32219156bb8c5fc4f47f9819efe3e02145de403
diff --git a/trinity-base/kdesktop/kdesktop-14.0.11.ebuild b/trinity-base/kdesktop/kdesktop-14.0.11.ebuild
new file mode 100644
index 00000000..6171eb01
--- /dev/null
+++ b/trinity-base/kdesktop/kdesktop-14.0.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="kcheckpass/ translations/ FindXscreensaver.cmake"
+inherit trinity-meta-2
+
+DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="pam xscreensaver hwlib"
+
+COMMON_DEPEND="
+ ~dev-libs/dbus-1-tqt-${PV}
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/libkonq-${PV}
+ x11-libs/libXrender
+ x11-libs/libXcursor
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+DEPEND="${COMMON_DEPEND}
+ xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
+RDEPEND="${COMMON_DEPEND}
+ ~trinity-base/kcheckpass-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/konqueror-${PV}
+ pam? ( trinity-base/tdebase-pam )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ -DWITH_XRENDER=ON
+ -DWITH_PAM="$(usex pam)"
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ -DTDESCREENSAVER_PAM_SERVICE=tde
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ )
+ trinity-meta-2_src_configure
+}