summaryrefslogtreecommitdiffstats
path: root/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/smartcardauth/smartcardauth-9999.ebuild')
-rw-r--r--trinity-apps/smartcardauth/smartcardauth-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/trinity-apps/smartcardauth/smartcardauth-9999.ebuild b/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
new file mode 100644
index 00000000..19630b77
--- /dev/null
+++ b/trinity-apps/smartcardauth/smartcardauth-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+inherit trinity-base-2
+
+DESCRIPTION="SmartCard login and LUKS decrypt"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" libressl"
+
+DEPEND+="
+ net-libs/gnutls
+ dev-libs/pkcs11-helper
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+"
+RDEPEND+=" ${DEPEND}"