summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/kchmviewer/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2014-05-27 13:20:16 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2014-05-27 13:20:16 +0900
commit229e7f5038cbc5f930ab50abfad3099919a4e8bb (patch)
tree569abf2cbc4bd05a0b90ed759ccd941eaa676c01 /debian/squeeze/applications/kchmviewer/debian/rules
parent59f50d7552dacb6d27d0768a9a5320e5ba2fc23d (diff)
parent50c481625fcb2361e0aaae71df24a40cbad056d7 (diff)
downloadtde-packaging-229e7f5038cbc5f930ab50abfad3099919a4e8bb.tar.gz
tde-packaging-229e7f5038cbc5f930ab50abfad3099919a4e8bb.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'debian/squeeze/applications/kchmviewer/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/kchmviewer/debian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/squeeze/applications/kchmviewer/debian/rules b/debian/squeeze/applications/kchmviewer/debian/rules
index e3fdf7aac..9f09d3cea 100755
--- a/debian/squeeze/applications/kchmviewer/debian/rules
+++ b/debian/squeeze/applications/kchmviewer/debian/rules
@@ -23,7 +23,7 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
CFLAGS = -Wall -g
-CONFIGURE_OPTIONS_KDE = \
+CONFIGURE_OPTIONS_TDE = \
--host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib \
--includedir=/opt/trinity/include/tde --mandir=/opt/trinity/share/man \
@@ -57,7 +57,8 @@ debian/build-kde:
test -e config.guess -a -L config.guess || \
ln -sf /usr/share/misc/config.guess config.guess
- mkdir build-kde && cd build-kde && ../configure CFLAGS="$(CFLAGS)" $(CONFIGURE_OPTIONS_KDE)
+ [ -d build-kde ] || mkdir build-kde
+ cd build-kde && ../configure CFLAGS="$(CFLAGS)" $(CONFIGURE_OPTIONS_TDE)
$(MAKE) -C build-kde
touch debian/build-kde