summaryrefslogtreecommitdiffstats
path: root/gentoo/Documentation/scripts/update-keywords-lists
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/Documentation/scripts/update-keywords-lists
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/Documentation/scripts/update-keywords-lists')
-rwxr-xr-xgentoo/Documentation/scripts/update-keywords-lists32
1 files changed, 32 insertions, 0 deletions
diff --git a/gentoo/Documentation/scripts/update-keywords-lists b/gentoo/Documentation/scripts/update-keywords-lists
new file mode 100755
index 000000000..9390cdfb0
--- /dev/null
+++ b/gentoo/Documentation/scripts/update-keywords-lists
@@ -0,0 +1,32 @@
+#!/bin/bash
+
+DOC="Documentation"
+KEYWORDS_LIVE="$DOC/trinity.live.keywords"
+KEYWORDS_3_5_13_2="$DOC/trinity.3.5.13.2.keywords"
+
+resort() {
+ cp "${1}" "${1}.bak"
+ cat "${1}.bak" | sort -u >"$1" && rm "${1}.bak"
+}
+
+find trinity-base/ trinity-apps/ -iname '*9999.ebuild' | while read eb; do
+ PN="$(basename $(dirname ${eb}))"
+ C="$(basename $(dirname $(dirname ${eb})))"
+ P="$(basename ${eb%%.ebuild})"
+ if ! grep "^~$C/$P " "${KEYWORDS_LIVE}" >/dev/null 2>&1; then
+ echo "~$C/$P **" | tee -a "${KEYWORDS_LIVE}"
+ fi
+done
+
+resort "${KEYWORDS_LIVE}"
+
+
+find trinity-base/ trinity-apps -iname '*3.5.13.2.ebuild' | while read eb; do
+ PN="$(basename $(dirname ${eb}))"
+ C="$(basename $(dirname $(dirname ${eb})))"
+ P="$(basename ${eb%%.ebuild})"
+ if ! grep "^~$C/$P" "${KEYWORDS_3_5_13_2}" >/dev/null 2>&1; then
+ echo "~$C/$P" | tee -a "${KEYWORDS_3_5_13_2}"
+ fi
+done
+resort "${KEYWORDS_3_5_13_2}"