summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild')
-rw-r--r--gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild b/gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild
new file mode 100644
index 000000000..9e41727b0
--- /dev/null
+++ b/gentoo/trinity-base/kaddressbook/kaddressbook-3.5.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdepim"
+
+inherit trinity-meta
+
+DESCRIPTION="The Trinity Address Book"
+KEYWORDS="~amd64 ~x86"
+IUSE+=" gnokii"
+
+COMMON_DEPEND=">=trinity-base/libkdepim-${PV}:${SLOT}
+ >=trinity-base/libkcal-${PV}:${SLOT}
+ >=trinity-base/certmanager-${PV}:${SLOT}
+ >=trinity-base/libkdenetwork-${PV}:${SLOT}
+ gnokii? ( app-mobilephone/gnokii )"
+
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+TSM_EXTRACT_ALSO="certmanager/lib/
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ libemailfunctions/"
+
+src_configure () {
+ mycmakeargs=(
+ $(cmake-utils_use_with gnokii GNOKII )
+ )
+ trinity-meta_src_configure
+}