summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/kmilo/files
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/kmilo/files
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/kmilo/files')
-rw-r--r--gentoo/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch67
l---------gentoo/trinity-base/kmilo/files/shared1
2 files changed, 68 insertions, 0 deletions
diff --git a/gentoo/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch b/gentoo/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch
new file mode 100644
index 000000000..f5830b6bb
--- /dev/null
+++ b/gentoo/trinity-base/kmilo/files/kdeutils-3.5.13.1-kmilo-fix-powerbook.patch
@@ -0,0 +1,67 @@
+diff --git a/ConfigureChecks.cmake b/ConfigureChecks.cmake
+index 14828bc..2766533 100644
+--- a/ConfigureChecks.cmake
++++ b/ConfigureChecks.cmake
+@@ -117,24 +117,21 @@ endif( )
+
+ ##### kmilo #####################################
+
+-if ( BUILD_KMILO )
++if( BUILD_KMILO )
+ # FIXME: If anybody will ever compile trinity for POWERPC and especialy for
+-# POWERBOOK he should test those checks and modules
+- if( WITH_POWERBOOK )
++# POWERBOOK he or she should test workability of those modules
++ if( WITH_POWERBOOK OR WITH_POWERBOOK2 )
++ check_library_exists( "pbb" "init_libpbb" "" HAVE_PBBIPC_LIBRARY )
+ check_include_file( "pbbipc.h" HAVE_PBBIPC_H )
+- if( NOT HAVE_PBBIPC_H )
+- tde_message_fatal( "pbbipc.h header is required, but was not found on your system" )
+- endif( NOT HAVE_PBBIPC_H )
+- endif( WITH_POWERBOOK )
+-
+- if( WITH_POWERBOOK2 )
+ check_include_file( "pbb.h" HAVE_PBB_H )
+- if( NOT HAVE_PBB_H )
+- tde_message_fatal( "pbb.h header is required, but was not found on your system" )
+- endif( NOT HAVE_PBB_H )
+- endif( WITH_POWERBOOK2 )
+-
+-endif (BUILD_KMILO)
++ if( HAVE_PBBIPC_LIBRARY AND ( ( WITH_POWERBOOK AND HAVE_PBBIPC_H ) OR
++ ( WITH_POWERBOOK2 AND HAVE_PBB_H ) ) )
++ set( PBB_LIBRARY pbb CACHE INTERNAL "" )
++ else()
++ tde_message_fatal( "suitable pbbuttonosd is required, but was not found on your system" )
++ endif()
++ endif( WITH_POWERBOOK OR WITH_POWERBOOK2 )
++endif( BUILD_KMILO )
+
+
+ ##### ksim ######################################
+diff --git a/kmilo/powerbook/CMakeLists.txt b/kmilo/powerbook/CMakeLists.txt
+index 461d2d2..bb98b70 100644
+--- a/kmilo/powerbook/CMakeLists.txt
++++ b/kmilo/powerbook/CMakeLists.txt
+@@ -28,7 +28,7 @@ link_directories(
+
+ tde_add_kpart( kmilo_powerbook AUTOMOC
+ SOURCES pb_monitor.cpp
+- LINK kio-shared kmilo-shared
++ LINK kio-shared kmilo-shared ${PBB_LIBRARY}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+ )
+
+diff --git a/kmilo/powerbook2/CMakeLists.txt b/kmilo/powerbook2/CMakeLists.txt
+index 461d2d2..bb98b70 100644
+--- a/kmilo/powerbook2/CMakeLists.txt
++++ b/kmilo/powerbook2/CMakeLists.txt
+@@ -28,7 +28,7 @@ link_directories(
+
+ tde_add_kpart( kmilo_powerbook AUTOMOC
+ SOURCES pb_monitor.cpp
+- LINK kio-shared kmilo-shared
++ LINK kio-shared kmilo-shared ${PBB_LIBRARY}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+ )
+
diff --git a/gentoo/trinity-base/kmilo/files/shared b/gentoo/trinity-base/kmilo/files/shared
new file mode 120000
index 000000000..af62be31d
--- /dev/null
+++ b/gentoo/trinity-base/kmilo/files/shared
@@ -0,0 +1 @@
+../../../eclass/trinity-shared-files/ \ No newline at end of file