summaryrefslogtreecommitdiffstats
path: root/redhat/applications/katapult/katapult-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2015-03-29 19:51:50 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2015-03-29 19:51:50 +0200
commit18f810abbfb37865bc5c22777933ebe95b0bd109 (patch)
treeba4c16cd0b0239e602ecdada9983c0466453252d /redhat/applications/katapult/katapult-14.0.0.spec
parentfdf9448db901f04f52a2d778fe818b932d27a6b0 (diff)
downloadtde-packaging-18f810abbfb37865bc5c22777933ebe95b0bd109.tar.gz
tde-packaging-18f810abbfb37865bc5c22777933ebe95b0bd109.zip
RPM Packaging: update katapult
Diffstat (limited to 'redhat/applications/katapult/katapult-14.0.0.spec')
-rw-r--r--redhat/applications/katapult/katapult-14.0.0.spec89
1 files changed, 63 insertions, 26 deletions
diff --git a/redhat/applications/katapult/katapult-14.0.0.spec b/redhat/applications/katapult/katapult-14.0.0.spec
index f7f079136..2ce578dda 100644
--- a/redhat/applications/katapult/katapult-14.0.0.spec
+++ b/redhat/applications/katapult/katapult-14.0.0.spec
@@ -1,52 +1,77 @@
-# Default version for this component
-%define tde_pkg katapult
+#
+# spec file for package katapult (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# TDE specific building variables
+%define tde_pkg katapult
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
Name: trinity-%{tde_pkg}
-Summary: Faster access to applications, bookmarks, and other items.
+Epoch: %{tde_epoch}
Version: 0.3.2.1
-Release: %{?!preversion:8}%{?preversion:7_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: Faster access to applications, bookmarks, and other items.
Group: Applications/Utilities
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
URL: http://www.trinitydesktop.org/
-Prefix: %{tde_prefix}
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
%description
Katapult is an application for TDE, designed to allow faster access to
@@ -56,10 +81,14 @@ plugins as well, so its appearance is completely customizable. It was
inspired by Quicksilver for OS X.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -103,6 +132,13 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -f %{?buildroot}%{tde_libdir}/*.so
%__rm -f %{?buildroot}%{tde_libdir}/*.la
+# Fix desktop files (openSUSE only)
+echo "OnlyShowIn=TDE;" >>"%{?buildroot}%{tde_tdeappdir}/katapult.desktop"
+%if 0%{?suse_version}
+%suse_update_desktop_file -G "Application Launcher" katapult DesktopUtility
+%endif
+
+
%clean
%__rm -rf %{buildroot}
@@ -115,6 +151,7 @@ done
/sbin/ldconfig || :
update-desktop-database %{tde_appdir} &> /dev/null
+
%postun
for f in crystalsvg hicolor ; do
touch --no-create %{tde_datadir}/icons/${f} || :
@@ -177,5 +214,5 @@ update-desktop-database %{tde_appdir} &> /dev/null
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.3.2.1-8
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2:0.3.2.1-1
- Initial release for TDE 14.0.0