summaryrefslogtreecommitdiffstats
path: root/redhat/applications/knmap/knmap-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2018-11-27 21:34:48 +0100
commita615d19df88eb2e989316b480519161945dbc7dc (patch)
tree369970b98042998b86c11024598155e037b76fec /redhat/applications/knmap/knmap-14.0.0.spec
parent76a93e0011ade1583a1ec672f33411dfd35454f3 (diff)
downloadtde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.tar.gz
tde-packaging-a615d19df88eb2e989316b480519161945dbc7dc.zip
RPM: merge redhat directory with master branch
Diffstat (limited to 'redhat/applications/knmap/knmap-14.0.0.spec')
-rw-r--r--redhat/applications/knmap/knmap-14.0.0.spec124
1 files changed, 76 insertions, 48 deletions
diff --git a/redhat/applications/knmap/knmap-14.0.0.spec b/redhat/applications/knmap/knmap-14.0.0.spec
index 5f1acaa39..df8bb92f3 100644
--- a/redhat/applications/knmap/knmap-14.0.0.spec
+++ b/redhat/applications/knmap/knmap-14.0.0.spec
@@ -1,50 +1,86 @@
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
+#
+# spec file for package knmap (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
+%if "%{?tde_version}" == ""
+%define tde_version 14.0.0
%endif
-
-# Default version for this component
%define tde_pkg knmap
-%define tde_version 14.0.0
-
-# TDE specific building variables
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-Name: trinity-%{tde_pkg}
-Version: 2.1
-Release: %{?!preversion:2}%{?preversion:1_%{preversion}}%{?dist}%{?_variant}
-Summary: An NMAP frontend for TDE
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 2.1
+Release: %{?tde_version}_%{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+Summary: An NMAP frontend for TDE
+Group: Applications/Internet
+URL: http://sourceforge.net/projects/knmap/
+
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Group: Applications/Internet
-License: GPLv2+
-URL: http://sourceforge.net/projects/knmap/
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: gettext
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: libtool
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# NMAP support
Requires: nmap
+
%description
Knmap is a TDE-based interface to the 'nmap' facility.
@@ -57,26 +93,29 @@ released on 2003-03-09 and targeted the KDE 2.2 and QT 2.3 environments.
Not to mention that it did not cater for the full set of 'nmap' options.
Or, perhaps, 'nmap' progressed whilst that version of Knmap languished.
- .
+
http://www.kde-apps.org/content/show.php?content=31108
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
%configure \
--prefix=%{tde_prefix} \
@@ -101,33 +140,27 @@ export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
%__rm -rf $RPM_BUILD_ROOT
%__make install DESTDIR=$RPM_BUILD_ROOT
+# Move desktop icon to XDG directory
+%__mkdir_p %{buildroot}%{tde_tdeappdir}
+%__mv "%{buildroot}%{tde_datadir}/applnk/"*"/%{tde_pkg}.desktop" "%{buildroot}%{tde_tdeappdir}/%{tde_pkg}.desktop"
+%__rm -r "%{buildroot}%{tde_datadir}/applnk"
-%clean
-%__rm -rf $RPM_BUILD_ROOT
-
-
-%post
-for i in hicolor ; do
- touch --no-create %{tde_datadir}/icons/$i 2>/dev/null || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/$i 2>/dev/null || :
-done
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -r %{tde_pkg} TDE System Network
+%endif
-%postun
-for i in hicolor ; do
- touch --no-create %{tde_datadir}/icons/$i 2>/dev/null || :
- gtk-update-icon-cache --quiet %{tde_datadir}/icons/$i 2>/dev/null || :
-done
+%clean
+%__rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING README ChangeLog
%{tde_bindir}/knmap
-%{tde_datadir}/applnk/Internet/knmap.desktop
-%{tde_datadir}/apps/knmap/knmapui.rc
-%{tde_datadir}/apps/knmap/nmap_manpage.html
-%{tde_datadir}/apps/knmap/nmap_manpage.html.diff
+%{tde_tdeappdir}/knmap.desktop
+%{tde_datadir}/apps/knmap/
%{tde_tdedocdir}/HTML/en/knmap/
%{tde_datadir}/icons/hicolor/*/apps/knmap.png
%{tde_datadir}/icons/hicolor/*/apps/knmapman.png
@@ -150,8 +183,3 @@ done
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2.1-2
-- Initial release for TDE 14.0.0
-
-* Mon Apr 08 2013 Francois Andriot <francois.andriot@free.fr> - 2.1-1
-- Initial release for TDE 3.5.13.2