summaryrefslogtreecommitdiffstats
path: root/redhat/applications/system/knemo/knemo.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2024-06-13 08:37:13 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2024-06-13 08:38:31 +0200
commitac47c91c6c011631186592695e4251a3bb97dcca (patch)
treed91e4e98d96b4b2618d9fb3b879c28b67fc63a8f /redhat/applications/system/knemo/knemo.spec
parent1488354ed514d043f0c15ddbe8b9aa7c0b43f46c (diff)
downloadtde-packaging-ac47c91c6c011631186592695e4251a3bb97dcca.tar.gz
tde-packaging-ac47c91c6c011631186592695e4251a3bb97dcca.zip
RPM: synchronize redhat directory with r14.1.x branch
Signed-off-by: François Andriot <albator78@libertysurf.fr>
Diffstat (limited to 'redhat/applications/system/knemo/knemo.spec')
-rw-r--r--redhat/applications/system/knemo/knemo.spec30
1 files changed, 23 insertions, 7 deletions
diff --git a/redhat/applications/system/knemo/knemo.spec b/redhat/applications/system/knemo/knemo.spec
index b6f820d57..0b8398d96 100644
--- a/redhat/applications/system/knemo/knemo.spec
+++ b/redhat/applications/system/knemo/knemo.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg knemo
%define tde_prefix /opt/trinity
@@ -89,28 +89,44 @@ Requires: net-tools-deprecated
%endif
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# IDN support
BuildRequires: libidn-devel
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# Wireless support
-%define with_wifi 1
+# Wifi support
%if 0%{?fedora} >= 6 || 0%{?rhel} >= 5
-BuildRequires: wireless-tools-devel
+%define wifi_devel wireless-tools-devel
%endif
%if 0%{?mgaversion} == 2 || 0%{?mdkversion}
-BuildRequires: %{_lib}iw29-devel
+%define wifi_devel %{_lib}iw29-devel
%endif
%if 0%{?rhel} == 5 || 0%{?suse_version}
-BuildRequires: wireless-tools
+%define wifi_devel wireless-tools
%endif
%if 0%{?suse_version} || 0%{?mgaversion} >= 3
-BuildRequires: libiw-devel
+%define wifi_devel libiw-devel
%endif
+%if 0%{?mdkver}
+%define wifi_devel %nil
+%endif
+%if "%{wifi_devel}" != ""
+%define with_wifi 1
+BuildRequires: %{wifi_devel}
+%endif
+
%description
@@ -141,7 +157,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi