summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/codeine/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-06-25 16:00:22 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-06-29 12:51:54 +0900
commit549156df1542fed8ad3fc828ef42a8b07ece8c28 (patch)
tree006186f0467a6ea818176f364c15404fe0a7d6fc /ubuntu/_base/applications/codeine/debian/rules
parentf6c1fb89e14d2353f6aa81ddd2ce85c048b65306 (diff)
downloadtde-packaging-549156df1542fed8ad3fc828ef42a8b07ece8c28.tar.gz
tde-packaging-549156df1542fed8ad3fc828ef42a8b07ece8c28.zip
DEB: added support for codeine player.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/codeine/debian/rules')
-rwxr-xr-xubuntu/_base/applications/codeine/debian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/codeine/debian/rules b/ubuntu/_base/applications/codeine/debian/rules
new file mode 100755
index 000000000..18aa16b96
--- /dev/null
+++ b/ubuntu/_base/applications/codeine/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"