summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 23:02:46 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 23:02:46 +0900
commitfcad8b8d150fb9f508973e3044a103de74ec3877 (patch)
treeca34a8cf3bfbe08335d40c47863b4901e1d19609 /ubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules
parent5d8ed1fab813d86b04383f7fcf8ab2c994cbea30 (diff)
downloadtde-packaging-fcad8b8d150fb9f508973e3044a103de74ec3877.tar.gz
tde-packaging-fcad8b8d150fb9f508973e3044a103de74ec3877.zip
DEB: use _base folder for a distro instead of specific distros (squeeze and maverick).
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules')
-rwxr-xr-xubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules b/ubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules
new file mode 100755
index 000000000..7db927c4b
--- /dev/null
+++ b/ubuntu/_base/applications/qt4-tqt-theme-engine/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/class/qmake.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+QMAKE := qmake-qt4
+