summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/defaultsettings/desktop-base/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/_base/defaultsettings/desktop-base/debian/rules
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/defaultsettings/desktop-base/debian/rules')
-rwxr-xr-xubuntu/_base/defaultsettings/desktop-base/debian/rules30
1 files changed, 30 insertions, 0 deletions
diff --git a/ubuntu/_base/defaultsettings/desktop-base/debian/rules b/ubuntu/_base/defaultsettings/desktop-base/debian/rules
new file mode 100755
index 000000000..67ba1f7f8
--- /dev/null
+++ b/ubuntu/_base/defaultsettings/desktop-base/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/buildcore.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/makefile.mk
+
+pre-build:: debian/stamp-distrospecific
+
+debian/stamp-distrospecific:
+ dh_testdir
+ [ -e debian/stamp-distrospecific ] || \
+ ls -a1 debian/distrospecific | grep -v "^\.*$$" | \
+ tee debian/stamp-distrospecific | \
+ tr "\n" "\0" | (cd debian/distrospecific && xargs -r0 mv -t ../..)
+
+clean::
+ dh_testdir
+ [ ! -e debian/stamp-distrospecific ] || \
+ cat debian/stamp-distrospecific | \
+ tr "\n" "\0" | xargs -r0 mv -t debian/distrospecific
+ rm -f debian/stamp-distrospecific
+
+# needed for usplash
+CFLAGS += -fPIC
+
+DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/desktop-base-trinity/
+
+binary-fixup/desktop-base::
+ dh_gconf --priority=15
+