summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqt3/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-11-04 13:04:30 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-11-04 13:31:16 +0900
commit2b8fd47f124fb980fbcaf6a1def412782d20490b (patch)
treeb997e99e1a009bc814c4118e027515d5dc6bd857 /ubuntu/_base/dependencies/tqt3/debian/rules
parent78f8fb896f6c763e59f0e7a4e41c62534caf2071 (diff)
downloadtde-packaging-deb/tqt3/tqmake.tar.gz
tde-packaging-deb/tqt3/tqmake.zip
DEB tqt3: rename qmake to tqmakedeb/tqt3/tqmake
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/dependencies/tqt3/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqt3/debian/rules28
1 files changed, 14 insertions, 14 deletions
diff --git a/ubuntu/_base/dependencies/tqt3/debian/rules b/ubuntu/_base/dependencies/tqt3/debian/rules
index cb73bd445..9d2f4f987 100755
--- a/ubuntu/_base/dependencies/tqt3/debian/rules
+++ b/ubuntu/_base/dependencies/tqt3/debian/rules
@@ -191,9 +191,9 @@ libqt-thread-stamp: post-patches
cd tools/designer/tools/tqtconv2ui && $(MAKE)
cp bin/tqtconv2ui $(TMP_INSTALL)/usr/bin/tqtconv2ui
- # install qmake.cache file
+ # install tqmake.cache file
install -d $(P_QTMTDEV)/usr/share/tqt3/
- cat .qmake.cache | sed "s#$(QTDIR)#/usr/share/tqt3#g" > $(P_QTMTDEV)/usr/share/tqt3/.qmake.cache
+ cat .tqmake.cache | sed "s#$(QTDIR)#/usr/share/tqt3#g" > $(P_QTMTDEV)/usr/share/tqt3/.tqmake.cache
touch libqt-thread-stamp
@@ -213,10 +213,10 @@ clean::
$(MAKE) -C tools/msg2tqm distclean; $(MAKE) -C tools/tqtmergetr distclean; $(MAKE) -C tools/qembed distclean; \
$(MAKE) -C tools/designer/tools/tqtconv2ui distclean; $(MAKE) -C tools/designer/tools/tqtcreatecw distclean; \
$(MAKE) -C tools/designer/plugins/glade distclean; \
- $(MAKE) -C config.tests/unix/largefile distclean; $(MAKE) -C qmake distclean; \
+ $(MAKE) -C config.tests/unix/largefile distclean; $(MAKE) -C tqmake distclean; \
fi
- -rm -rf .qmake.cache src/.qmake.internal.cache tools/designer/designer/.qmake.internal.cache qmake/GNUmakefile \
+ -rm -rf .tqmake.cache src/.tqmake.internal.cache tools/designer/designer/.tqmake.internal.cache tqmake/GNUmakefile \
config.status bin/tqmoc bin/tqmake src/tqmoc/*.o mkspecs/default lib/lib* `pwd`/debian/doc $(TMP_INSTALL) \
src/tools/qconfig.cpp plugins/accessibleqtwidgets.prl \
config.tests/unix/ipv6/ipv6test config.tests/unix/ipv6/ipv6test.o config.tests/unix/ptrsize/ptrsizetest.o \
@@ -224,7 +224,7 @@ clean::
config.tests/unix/endian/endiantest lib/tqt-mt.pc extensions/nsplugin/examples/trivial/libtrivial.prl \
extensions/nsplugin/examples/grapher/libgrapher.prl bin/designer
- rm -f qmake/*o
+ rm -f tqmake/*o
rm -f src/.obj/debug-shared-mt/*o plugins/src/inputmethods/imsw-multi/.obj/debug-shared-mt/*o plugins/inputmethods/*so
rm -f plugins/src/inputmethods/imsw-none/.obj/debug-shared-mt/*o plugins/src/inputmethods/simple/.obj/debug-shared-mt/*o plugins/src/inputmethods/xim/.obj/debug-shared-mt/*o
@@ -344,8 +344,8 @@ binary-indep: build install
# logo32.png
cp `pwd`/doc/html/logo32.png `pwd`/debian/tqt3-doc/usr/share/tqt3/doc/html/
- # remove qmake html docu from tqt3-doc
- rm -rf `pwd`/debian/tqt3-doc/usr/share/tqt3/doc/html/qmake*
+ # remove tqmake html docu from tqt3-doc
+ rm -rf `pwd`/debian/tqt3-doc/usr/share/tqt3/doc/html/tqmake*
# create examples package
install -d `pwd`/debian/doc/tqt3-examples/tools/designer
@@ -436,14 +436,14 @@ binary-arch: build install
do cat "$$a" | sed 's/logo32/logo32-assistant/g' > "$$a".new && mv "$$a".new "$$a"; done
cd `pwd`/debian/tqt3-dev-tools/usr/share/tqt3/doc/html && for a in `find . -name '*.html'`; \
- do cat "$$a" | sed 's/logo32/logo32-qmake/g' > "$$a".new && mv "$$a".new "$$a"; done
+ do cat "$$a" | sed 's/logo32/logo32-tqmake/g' > "$$a".new && mv "$$a".new "$$a"; done
for a in designer linguist assistant; do install -m644 -D `pwd`/doc/html/logo32.png `pwd`/debian/tqt3-"$$a"/usr/share/tqt3/doc/html/logo32-"$$a".png; done
- install -m644 -D `pwd`/doc/html/logo32.png `pwd`/debian/tqt3-dev-tools/usr/share/tqt3/doc/html/logo32-qmake.png
+ install -m644 -D `pwd`/doc/html/logo32.png `pwd`/debian/tqt3-dev-tools/usr/share/tqt3/doc/html/logo32-tqmake.png
- # fix qmake.conf files
- cd `pwd`/debian/tqt3-dev-tools/usr/share/tqt3/mkspecs/ && for a in *; do cd "$$a" && cat qmake.conf | sed 's/\$$(QTDIR)\/include/\/usr\/share\/tqt3\/include/g' | sed 's/\$$(QTDIR)/\/usr\/share\/tqt3/g' | \
- sed 's/\-I\/usr\/include/&\/tqt3/g' >> qmake.conf.new && mv qmake.conf.new qmake.conf && cd ../; done
+ # fix tqmake.conf files
+ cd `pwd`/debian/tqt3-dev-tools/usr/share/tqt3/mkspecs/ && for a in *; do cd "$$a" && cat tqmake.conf | sed 's/\$$(QTDIR)\/include/\/usr\/share\/tqt3\/include/g' | sed 's/\$$(QTDIR)/\/usr\/share\/tqt3/g' | \
+ sed 's/\-I\/usr\/include/&\/tqt3/g' >> tqmake.conf.new && mv tqmake.conf.new tqmake.conf && cd ../; done
dh_link -ptqt3-designer usr/share/tqt3/doc/html usr/share/doc/tqt3-designer/html
dh_link -ptqt3-assistant usr/share/tqt3/doc/html usr/share/doc/tqt3-assistant/html
@@ -453,9 +453,9 @@ binary-arch: build install
# copy README.Debian
for a in libtqt3-mt-dev libtqt3-mt$(DEB_TIME64_SUFFIX) tqt3-doc; do install -D `pwd`/debian/README.Debian `pwd`/debian/"$$a"/usr/share/doc/"$$a"/README.Debian; done
- # install the qmake binary
+ # install the tqmake binary
rm -rf `pwd`/debian/tqt3-dev-tools/usr/bin/tqmake
- install -D `pwd`/qmake/tqmake `pwd`/debian/tqt3-dev-tools/usr/bin/tqmake
+ install -D `pwd`/tqmake/tqmake `pwd`/debian/tqt3-dev-tools/usr/bin/tqmake
# Install source for the designer tools, such as tqtcreatecw.
cp -ra tools/designer/tools debian/tqt3-designer/usr/share/tqt3/tools