summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kvpnc/debian/rules
diff options
context:
space:
mode:
authorFrancois Andriot <francois.andriot@free.fr>2011-12-10 00:52:28 +0100
committerFrancois Andriot <francois.andriot@free.fr>2011-12-10 00:52:28 +0100
commit0b0d138bbc895c01e392bf3fd6c4e916a86935a5 (patch)
tree3bd01a9b7276d77c891e2f1d061c121599f00a7f /ubuntu/maverick/applications/kvpnc/debian/rules
parent4368359c6192aaff174d4ec6fde1a8ae0682defa (diff)
parent947e6baf2df5b3171900c9acd928f06e0da77ac9 (diff)
downloadtde-packaging-0b0d138bbc895c01e392bf3fd6c4e916a86935a5.tar.gz
tde-packaging-0b0d138bbc895c01e392bf3fd6c4e916a86935a5.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/applications/kvpnc/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kvpnc/debian/rules42
1 files changed, 42 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kvpnc/debian/rules b/ubuntu/maverick/applications/kvpnc/debian/rules
new file mode 100755
index 000000000..8e7f6fc6f
--- /dev/null
+++ b/ubuntu/maverick/applications/kvpnc/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
+DEB_INSTALL_MANPAGES_kvpnc-trinity := debian/kvpnc-trinity.1
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+makebuilddir/kvpnc-trinity::
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+install/kvpnc-trinity::
+ # fix script-not-executable
+ chmod 0755 debian/kvpnc-trinity/opt/trinity/share/apps/kvpnc/ping_check.sh
+
+ # remove uneeded dir
+ rm -rf debian/kvpnc-trinity/opt/trinity/share/doc/kde/HTML/kvpnc
+
+ # install desktop file in applications
+ install -D -p -m0644 src/kvpnc.desktop \
+ debian/kvpnc-trinity/opt/trinity/share/applications/kde/kvpnc.desktop
+
+binary-post-install/kvpnc-trinity::
+ rm -rf debian/kvpnc-trinity/opt/trinity/share/applnk/
+
+clean::
+ rm -f config.status config.log
+ find . -type f -name '*.gmo' | xargs rm -f