summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2015-02-20 22:16:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2015-02-20 22:17:11 +0100
commitc71c05d686d40e2c4d8cc873a51b50d1cbb5dcde (patch)
tree0a3f8d14d850b54a2adc81806301419bd2c3b8a4 /ubuntu/maverick/dependencies/avahi-tqt/debian/rules
parentbd43cd469600f15aac2786fd0fa6bd1397aca611 (diff)
downloadtde-packaging-c71c05d686d40e2c4d8cc873a51b50d1cbb5dcde.tar.gz
tde-packaging-c71c05d686d40e2c4d8cc873a51b50d1cbb5dcde.zip
Switch avahi-tqt to cmake on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 3186c3943aea305c58774dc0d5f80aa9f78464fb)
Diffstat (limited to 'ubuntu/maverick/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/avahi-tqt/debian/rules20
1 files changed, 6 insertions, 14 deletions
diff --git a/ubuntu/maverick/dependencies/avahi-tqt/debian/rules b/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
index ac6ff10f3..4929325df 100755
--- a/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
+++ b/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
@@ -1,25 +1,17 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/class/cmake.mk
# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
-DEB_CONFIGURE_EXTRA_FLAGS += \
- --prefix=/usr \
- --enable-compat-libdns_sd \
- --disable-mono --disable-monodoc \
- --disable-gtk3 \
- --with-systemdsystemunitdir=/lib/systemd/system
+# Build options
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ./autogen.sh --prefix=/usr
- rm ./ChangeLog
- touch debian/stamp-bootstrap