summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/libart-lgpl/debian/rules
diff options
context:
space:
mode:
authorFrancois Andriot <francois.andriot@free.fr>2011-12-10 00:52:28 +0100
committerFrancois Andriot <francois.andriot@free.fr>2011-12-10 00:52:28 +0100
commit0b0d138bbc895c01e392bf3fd6c4e916a86935a5 (patch)
tree3bd01a9b7276d77c891e2f1d061c121599f00a7f /ubuntu/maverick/dependencies/libart-lgpl/debian/rules
parent4368359c6192aaff174d4ec6fde1a8ae0682defa (diff)
parent947e6baf2df5b3171900c9acd928f06e0da77ac9 (diff)
downloadtde-packaging-0b0d138bbc895c01e392bf3fd6c4e916a86935a5.tar.gz
tde-packaging-0b0d138bbc895c01e392bf3fd6c4e916a86935a5.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/dependencies/libart-lgpl/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/libart-lgpl/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/ubuntu/maverick/dependencies/libart-lgpl/debian/rules b/ubuntu/maverick/dependencies/libart-lgpl/debian/rules
new file mode 100755
index 000000000..4390434f7
--- /dev/null
+++ b/ubuntu/maverick/dependencies/libart-lgpl/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include /usr/share/cdbs/1/class/gnome.mk
+include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
+include /usr/share/gnome-pkg-tools/1/rules/clean-la.mk
+-include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk
+
+makebuilddir/kvpnc-trinity::
+ cp -Rp /usr/share/aclocal/libtool.m4 libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh ltmain.sh
+ autoconf
+ automake
+
+libart-2.0-N := $(shell sed -rn 's/^Package:[[:space:]]*(libart-2\.0-[0-9]+)[[:space:]]*$$/\1/p' debian/control)
+
+GNOME_MODULE := libart_lgpl
+
+DEB_DH_MAKESHLIBS_ARGS_$(libart-2.0-N) += -V '$(libart-2.0-N)(>= 2.3.18)'
+