summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/python-tqt/debian/rules
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-08-27 21:17:52 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-08-27 21:17:52 +0200
commit1af57210e2e55d40eb39a274fcf48779c6b9e7d5 (patch)
tree55c22bbd35462f1c940b24614af05ea07bcd7f35 /ubuntu/maverick/dependencies/python-tqt/debian/rules
parentaf8c5ead9ac4c1ece3408b74224e5e273b6994ce (diff)
parent2d0d0ba99b507cab093962cb910ddc7dd4755c94 (diff)
downloadtde-packaging-1af57210e2e55d40eb39a274fcf48779c6b9e7d5.tar.gz
tde-packaging-1af57210e2e55d40eb39a274fcf48779c6b9e7d5.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/dependencies/python-tqt/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/python-tqt/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/ubuntu/maverick/dependencies/python-tqt/debian/rules b/ubuntu/maverick/dependencies/python-tqt/debian/rules
index 86eca95c9..b0acb35f6 100755
--- a/ubuntu/maverick/dependencies/python-tqt/debian/rules
+++ b/ubuntu/maverick/dependencies/python-tqt/debian/rules
@@ -32,6 +32,9 @@ CXXFLAGS += "-I/usr/include/tqt"
PYTHONS := $(shell pyversions -vr debian/control)
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -154,7 +157,7 @@ endif
# dh_strip
dh_compress -X.py -X.bmp -X.ui -X.sql
dh_fixperms
- dh_pysupport
+ ${DH_PYTHON2}
dh_sip
dh_lintian
dh_installdeb