summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/python-tqt/debian/rules
diff options
context:
space:
mode:
authorCalvin Morrison <mutantturkey@gmail.com>2011-12-14 15:50:42 -0500
committerCalvin Morrison <mutantturkey@gmail.com>2011-12-14 15:50:42 -0500
commitfc98476aef6bf17768cfc0450bd25ac967d01834 (patch)
tree7411b50fd18336185de9fb8520fd9154822020b4 /ubuntu/maverick/dependencies/python-tqt/debian/rules
parentcc3f13111c121c8a39b9937bb2e1bf00207c9df0 (diff)
parente9bf572672fe20775479a10b426d32379f4185d0 (diff)
downloadtde-packaging-fc98476aef6bf17768cfc0450bd25ac967d01834.tar.gz
tde-packaging-fc98476aef6bf17768cfc0450bd25ac967d01834.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/dependencies/python-tqt/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/python-tqt/debian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/ubuntu/maverick/dependencies/python-tqt/debian/rules b/ubuntu/maverick/dependencies/python-tqt/debian/rules
index 0e74c131e..ebb91c6e4 100755
--- a/ubuntu/maverick/dependencies/python-tqt/debian/rules
+++ b/ubuntu/maverick/dependencies/python-tqt/debian/rules
@@ -25,6 +25,7 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
else
CXXFLAGS += -O1
endif
+CXXFLAGS += "-I/usr/include/tqt"
PYTHONS := $(shell pyversions -vr debian/control)
@@ -44,7 +45,7 @@ build-%/configure-stamp:
mkdir -p build-$*
cd build-$* && echo yes \
| python$* ../configure.py \
- -c -n /usr/include/qscintilla \
+ -c -n /usr/include/tqscintilla \
-o /usr/lib -u -j $(SPLIT) \
-d /usr/lib/python$*/$(call py_sitename,$*) \
-l /usr/include/python$* \
@@ -58,13 +59,13 @@ dbg-build-%/configure-stamp:
mkdir -p dbg-build-$*
cd dbg-build-$* && echo yes \
| python$*-dbg ../configure.py \
- -c -n /usr/include/qscintilla \
+ -c -n /usr/include/tqscintilla \
-o /usr/lib -u -j $(SPLIT) \
-d /usr/lib/python$*/$(call py_sitename,$*) \
-l /usr/include/python$*_d \
-v /usr/share/sip/tqt \
-m /usr/lib/python$*/config_d \
- CXXFLAGS_RELEASE="" CXXFLAGS="-O0 -g" STRIP=""
+ CXXFLAGS_RELEASE="" CXXFLAGS="-O0 -g -I/usr/include/tqt" STRIP=""
touch $@
build: $(PYTHONS:%=build-%/build-stamp) $(PYTHONS:%=dbg-build-%/build-stamp)
@@ -87,7 +88,7 @@ install-indep: configure
for version in ${PYTHONS}; do\
pylib=$$(python$$version -c 'from distutils import sysconfig; print sysconfig.get_python_lib()'); \
mkdir -p debian/python-tqt-dev/$$pylib;\
- install -m 644 -o root -g root build-$$version/pytqtconfig.py debian/python-tqt-dev/$$pylib;\
+ install -m 644 -o root -g root build-$$version/pyqtconfig.py debian/python-tqt-dev/$$pylib;\
done
dh_install -i
@@ -105,7 +106,7 @@ install-arch: build
mkdir -p debian/python-tqt-gl-dbg/$$pylib;\
mv debian/python-tqt-dbg/$$pylib/qtgl.so \
debian/python-tqt-gl-dbg/$$pylib/;\
- mkdir -p debian/python-qtext-dbg/$$pylib;\
+ mkdir -p debian/python-tqtext-dbg/$$pylib;\
mv debian/python-tqt-dbg/$$pylib/qtext.so \
debian/python-tqtext-dbg/$$pylib/;\
done