summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/qt3/debian/rules
diff options
context:
space:
mode:
authorFrancois Andriot <francois.andriot@free.fr>2013-01-03 22:47:53 +0100
committerFrancois Andriot <francois.andriot@free.fr>2013-01-03 22:47:53 +0100
commitd2f32337f00cf98faef8475e769d9c0381efd257 (patch)
tree9890ceb134945c4f24e624dca8ac4fa03888a979 /ubuntu/maverick/dependencies/qt3/debian/rules
parentb566058ccb7fa94c6e34fb1e1349b093d4482d6a (diff)
parentfe7329f1eaa98f63b62e23449bb1345b3395ed37 (diff)
downloadtde-packaging-d2f32337f00cf98faef8475e769d9c0381efd257.tar.gz
tde-packaging-d2f32337f00cf98faef8475e769d9c0381efd257.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/dependencies/qt3/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/qt3/debian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/ubuntu/maverick/dependencies/qt3/debian/rules b/ubuntu/maverick/dependencies/qt3/debian/rules
index 09b237823..7ede42ad9 100755
--- a/ubuntu/maverick/dependencies/qt3/debian/rules
+++ b/ubuntu/maverick/dependencies/qt3/debian/rules
@@ -11,6 +11,9 @@ export LD_LIBRARY_PATH=$(QTDIR)/lib:$(OLD_LD_LIBRARY_PATH)
OLD_PATH := $(PATH)
export PATH=$(QTDIR)/bin:$(OLD_PATH)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -96,6 +99,7 @@ CONFIGURE_OPTS = \
\
-lfontconfig \
-inputmethod \
+ -glibmainloop \
# End of CONFIGURE_OPTS
interbase_archs := i386 amd64 sparc powerpc
@@ -326,7 +330,7 @@ binary-indep: build install
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
binary-arch: build install
@@ -468,7 +472,7 @@ binary-arch: build install
dh_gencontrol -a $(IBASE)
dh_md5sums -a $(IBASE)
- dh_builddeb -a $(IBASE)
+ dh_builddeb -a $(IBASE) $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build binary-indep binary-arch binary install clean patch unpatch